Tuesday, November 12, 2013

Virtualbox Shared Folder access from Guest Machine

Virtualbox's Install Guest Additional (VBoxGuestAdditions.iso)

#svcadm restart volfs

#pkgadd -G -d ./VBoxSolarisAdditions.pkg

#mount -F vboxfs -r installers /mnt (note: c:\installers)

vi /etc/vfstab
installers          -         /mnt        vboxfs     -      yes       -
Solaris10 - /mrkips_vista vboxfs - ye


#pkgrm SUNWvboxguest

Reference: http://www.virtualbox.org/manual/ch04.html

VirtualBox Manager Command

Sometimes you will find the problem "The selected virtual machine is inaccessible" and obviously you can't access VMs you've created. In my case I just deleted all the VMs directly from the C: Drive.
When I open the virtual box all the virtual machine grey out and inaccessible.
In my case I just no longer needed for those VMs. So delete all the files under C:\Users\zawhtet\.VirtualBox

OR

You want to unregister the VMs from the Command Prompt,

First List the VMs to check the status

C:\Program Files\Oracle\VirtualBox\VBoxManage.exe list vms
"precise64" {3613de48-6295-4a91-81fd-36e936beda4b}
"" {2568227e-e73d-4056-978e-9ae8596493d9}
"" {0fb42965-61cb-4388-89c4-de572d4ea7fc}
"" {c65b1456-5771-4617-a6fb-869dffebeddd}
"" {9709d3d5-ce4d-42b9-ad5e-07726823fd02}

 One of those VMs flagged as inaccessible is my lost VM! Time to fix VBoxManage's wagon, by unregistering the VM as inaccessible, then re-registering it with the correct name:
  1. Open the configuration file for your lost VM. Mine was saved to C:\Users\zawhtet\VirtualBox VMsrails-vm-v2\rails-vm-v2.vbox
  2. Find and copy the value of the uuid attribute of the Machine node. Mine was 9709d3d5-ce4d-42b9-ad5e-07726823fd02 
  3. In a command prompt (or Cygwin terminal), unregister the VM with the unregistervm command, using the [uuid] value from step 2: C:\Program Files\Oracle\VirtualBox\VBoxManage.exe unregistervm 9709d3d5-ce4d-42b9-ad5e-07726823fd02 
  4. Now register the VM using the registervm command, with the path to the VM configuration file:
    C:\Program Files\Oracle\VirtualBox\VBoxManage.exe registervm C:\Users\zawhtet\VirtualBox VMsrails-vm-v2\rails-vm-v2.vbox





No comments: