1.If you intend not to register the system
#regadm status
#regadm disable
2. Download and mount the sol-10-u11-ga-x86-dvd.iso
#mount -F hsfs -o ro /dev/lofi/1 /mnt
3.Remove the package and install the latest package from the dvd image
#pkgrm SUNWlucfg SUNWluu SUNWlur
#cd /media/Solaris_10/Tools/Installers
#./liveupgrade20 -noconsole - nodisplay
4.Check the packages
#pkgchk -v SUNWlucfg SUNWlur SUNWluu
5. Current the system using SCSI drive with root partition - /dev/dsk/c0t1d0s0
6. I gonna add one more SCSI HDD to the solaris box - /dev/dsk/c1t1d0
Note:
/dev/rdsk/c0d0s0 - IDE Drive (/dev/dsk/c1t1d0s0,s1,s3,s4,s5,s6,s7) s2=overlap,s7=/export/home
/dev/rdsk/c0t0d0 - SCSI Drive
/dev/dsk/c0t0d0p0 - DVD Drive
#devfsadm
#drvconfig ( configure the /devices directory )
#disks ( creates /dev entries for hard disks attached to the system )
format > fdisk
No fdisk table exists. The default partition for the disk is:
a 100% “SOLARIS System” partition
Type “y” to accept the default partition, otherwise type “n” to edit the
partition table.
y
format > partition
partition > print (Please Mark the Cylinder number)
partition > 0
Part Tag Flag Cylinders Size Blocks
0 unassigned wm 0 0 (0/0/0) 0
Enter partition id tag[unassigned]:
Enter partition permission flags[wm]:
Enter new starting cyl[0]: 1
Enter partition size[0b, 0c, 1e, 0.00mb, 0.00gb]: 1gb - depends on Cylinder Size
partition > print
partition > label
Ready to label disk, continue? y
partition > quit
format > quit
#newfs /dev/rdsk/c1t1d0s0
newfs: construct a new file system /dev/rdsk/c1t1d0s0: (y/n)? y
#fsck /dev/rdsk/c1t1d0s0
7. Setup the partitions on the new disk to be identical to the current system.
#prtvtoc /dev/rdsk/c0t0d0s0 | fmthard -s - /dev/rdsk/c1t1d0s0
Optional: no need to do the automount / we just want to use /dev/dsk/c1t1d0s0
Next, add the proper line to /etc/vfstab:
/dev/dsk/c1t1d0s0 /dev/rdsk/c1t1d0s0 /data ufs 2 yes -
# mkdir /data
# mount /data
# df -h /data
8. Creating a BE with name solenv2 and naming the current BE as solenv1, the merged keyword is used to indicate that we are merging it with the parent FS.
#lucreate -c solenv1 -m /:/dev/dsk/c1t1d0s0:ufs -m /var:merged:ufs -n solenv2
/var = separate partition and gonna merge
#lucreate -c solenv1 -m /:/dev/dsk/c1t1d0s0:ufs -n solenv2
9. Before you run luupgrade command you need to disable autoreg
echo "autoreg=disable" > /var/tmp/no-autoreg
10. Run update from the DVD
#luupgrade -u -k /var/tmp/no-autoreg -n solenv2 -s /media/
11. check the Live upgrade status
#lustatus
solenv1 yes yes yes no -
solenv2 yes no no yes -
12.Check current boot BE
#lucurr
13.Activate the BE solenv2
#luactivate solenv2
14.Reboot the system with 'init 6'
15.cat /etc/release
16.Check and save the patch compatibility with
#showrev -p - showrev.lst
17#Now you can delete solenv2
#ludelete -F solenv2
#regadm status
#regadm disable
2. Download and mount the sol-10-u11-ga-x86-dvd.iso
After you inserted the DVD
#mount /dev/dsk/c0t0d0p0 /media
Mount iso file directly
#lofiadm -a /tmp/sol-10-u11-ga-x86-dvd.iso /dev/lofi/1#mount -F hsfs -o ro /dev/lofi/1 /mnt
3.Remove the package and install the latest package from the dvd image
#pkgrm SUNWlucfg SUNWluu SUNWlur
#cd /media/Solaris_10/Tools/Installers
#./liveupgrade20 -noconsole - nodisplay
4.Check the packages
#pkgchk -v SUNWlucfg SUNWlur SUNWluu
5. Current the system using SCSI drive with root partition - /dev/dsk/c0t1d0s0
6. I gonna add one more SCSI HDD to the solaris box - /dev/dsk/c1t1d0
Note:
/dev/rdsk/c0d0s0 - IDE Drive (/dev/dsk/c1t1d0s0,s1,s3,s4,s5,s6,s7) s2=overlap,s7=/export/home
/dev/rdsk/c0t0d0 - SCSI Drive
/dev/dsk/c0t0d0p0 - DVD Drive
Check current drive status
# ls /dev/rdsk/*s0#devfsadm
#drvconfig ( configure the /devices directory )
#disks ( creates /dev entries for hard disks attached to the system )
Check again for new HDD
#ls /dev/rdsk/*s0
To format and partition the HDD
# format
Choose new HDD to format
format > fdisk
No fdisk table exists. The default partition for the disk is:
a 100% “SOLARIS System” partition
Type “y” to accept the default partition, otherwise type “n” to edit the
partition table.
y
format > partition
partition > print (Please Mark the Cylinder number)
partition > 0
Part Tag Flag Cylinders Size Blocks
0 unassigned wm 0 0 (0/0/0) 0
Enter partition id tag[unassigned]:
Enter partition permission flags[wm]:
Enter new starting cyl[0]: 1
Enter partition size[0b, 0c, 1e, 0.00mb, 0.00gb]: 1gb - depends on Cylinder Size
partition > print
partition > label
Ready to label disk, continue? y
partition > quit
format > quit
#newfs /dev/rdsk/c1t1d0s0
newfs: construct a new file system /dev/rdsk/c1t1d0s0: (y/n)? y
#fsck /dev/rdsk/c1t1d0s0
7. Setup the partitions on the new disk to be identical to the current system.
#prtvtoc /dev/rdsk/c0t0d0s0 | fmthard -s - /dev/rdsk/c1t1d0s0
Optional: no need to do the automount / we just want to use /dev/dsk/c1t1d0s0
Next, add the proper line to /etc/vfstab:
/dev/dsk/c1t1d0s0 /dev/rdsk/c1t1d0s0 /data ufs 2 yes -
And then mount the partition. In this case, I’m making a /data partition:
# mkdir /data
# mount /data
# df -h /data
8. Creating a BE with name solenv2 and naming the current BE as solenv1, the merged keyword is used to indicate that we are merging it with the parent FS.
#lucreate -c solenv1 -m /:/dev/dsk/c1t1d0s0:ufs -m /var:merged:ufs -n solenv2
example -
#lucreate -c solenv1 -m /:/dev/dsk/c1t1d0s0:ufs -m -:/dev/dsk/c1t1d0s1:swap -n solenv2/var = separate partition and gonna merge
OR just make
#lucreate -c solenv1 -m /:/dev/dsk/c1t1d0s0:ufs -n solenv2
9. Before you run luupgrade command you need to disable autoreg
echo "autoreg=disable" > /var/tmp/no-autoreg
10. Run update from the DVD
#luupgrade -u -k /var/tmp/no-autoreg -n solenv2 -s /media/
11. check the Live upgrade status
#lustatus
solenv1 yes yes yes no -
solenv2 yes no no yes -
12.Check current boot BE
#lucurr
13.Activate the BE solenv2
#luactivate solenv2
14.Reboot the system with 'init 6'
After reboot the system
15.cat /etc/release
It must show
Oracle Solaris 10 1/13 s10x_u11wos_24a X8616.Check and save the patch compatibility with
#showrev -p - showrev.lst
17#Now you can delete solenv2
#ludelete -F solenv2
No comments:
Post a Comment